
Documentation & Quick Start



Thank you!

Thank you for choosing this pack! We hope you create something 
really special with it. 

Please consider rating the package through your download list or 
leave a review at the store page once you’re familiar with it. 
Feel free to give us feedback via E-Mail info@tidalflask.com 

or our social media!
Your feedback helps us focus on the right updates for the future 

which will be free for existing users!

Enjoy, your Tidal Flask team!
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Quick StartQuick Start

Importing to Built-in RP project
After importing the Standard version into your Unity project 2019.4.30 & above, which 
doesn’t use any of the Scriptable render pipeline packages (URP/HDRP), it should just 
worktm.

If you see any warnings in the Console window, try the Clear button and/or relaunch 
Unity. If the warnings don’t disappear consult the FAQ or drop us an e-mail.
If you see any pink assets inside the Project window or in the scenes, simply select said 
asset -> right click -> Reimport and it should fix it. If you still encounter pink shaders, 
please make sure you have the correct pack version installed and that you are using a 
Unity version that is compatible with the pack. 

Make sure you have Post Processing installed from Unity’s Package Manager. If you in-
stall it after you imported the pack, reload the demoscene to get rid of possible errors.

Using an older Unity version than 2019.4.30
If you purchased this pack with version 1.8 or lower you can also import the updated 
pack into Unity version 2019.1.0 and up to the latest 2019.3.x version. 
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Importing to URP project

Additionally to the built-in RP version, this pack also includes a version which works 
with the Universal Render Pipeline. If you want to find out exactly what it can and can’t 
do please visit this page:
https://docs.unity3d.com/Manual/render-pipelines.html

Since Unity 2019.3 the LWRP is renamed to Universal Render Pipeline (URP). Make sure 
you are importing the URP version of our package if you are using URP and Unity ver-
sion 2019.4.30 or above.
On the following pages you will find detailed steps on how to import the package.

Lightweight Render Pipeline (LWRP) and 

Universal Render Pipeline (URP)
Our latest pack update no longer supports LWRP due to Unity discontinuing LWRP de-
velopment. In case you purchased this pack with version 1.1 or lower and are using 
LWRP you still can update your project with the latest pack version, but keep in mind to 
back up your project and use the legacy LWRP shaders.



6

We recommend to create a clean project and install the URP via the Package 
Manager or via Templates and import our package to this project. 
To do so follow the steps below:

How to set up your project for URP (option 1)

Step 1: Click “NEW” to create a new project (for URP pick Unity 2019.4.30 or above).

Step 2: In the “Templates” select “Universal RP”, this way everything you need for this 
package will be preinstalled.
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Step 3: Download the pack from the Asset Store and install the URP version.
At this point you already can go to the scenes folder and select any of the scenes.

If you see any errors in the “Console”, try the “Clear” button. If the errors don’t 
disappear consult the FAQ or drop us an e-mail.

If you see any pink assets inside the Project window or inside the “Terrain”-object in any 
of the scenes, simply select the said Prefabs (inside the prefabs folder) or the Meshes 
(inside the 3d folder) > right click > Reimport and it should fix it. 

If you still encounter pink shaders, please make sure you have the correct pack version 
installed, depending on the render pipeline you are using.
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Step 4: After the project is loaded, go to Edit > Project Settings...

Step 5: For the Scriptable Render Pipeline Settings select “UniversalRP_HighQuality”. 
These are the presets Unity preinstalled with the Template. 
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If you imported the pack before you installed the URP please follow the steps below:

How to set up your project for URP (option 2)

Step 1: go the Window > Package Manager.

Step 2: Select “Universal RP” asset and click “Install”.
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Step 3: After the project is loaded, go to Edit > Project Settings...

Step 4: For the Scriptable Render Pipeline Settings select “UniversalRP_HighQuality”. 
These are the presets Unity preinstalled with the Template.
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Demoscenes
demoscene_dungeon_assets_modular: all modular Parts, Comps and Level Modules 
can be found here. There are also some comments and explanation to get you going. 
demoscene_dungeon_assets_props: in this scene you will find all the props within the 
package.
demoscene_dungeon_level_1_dungeon: the biggest scene of the pack
demoscene_dungeon_level_2_entrance: small demoscene
demoscene_dungeon_level_3_hall: small demoscene
demoscene_dungeon_level_4_temple: small demoscene 
demoscene_dungeon_level_5_bossroom: small demoscene

All the sceneries you see in the trailer were recorded directly out of these Unity scenes 
with baked lights.
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Inside the \Fantastic Dungeon Pack\Settings folder you will find all Post Processing files 
for the demoscenes. There you can adjust the postprocessing to your liking.

Post Processing

To quickly adjust any quality settings for URP please find  the UniversalRP-HighQuality 
asset inside the \Assets\Settings folder.

Quality settings for URP

Example settings for shadows in the render pipeline asset.

The post processing settings.
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Assets

Tileable materials

Textures & Materials
You can find all the textures in the \2d\textures folder. The materials are in the 
\materials folder. 

•	 M_MOD_Floor_01_v3
•	 M_MOD_Trim_Stone_01_v3
•	 M_MOD_Wall_01_v1
•	 M_MOD_Wall_01_v3
•	 M_PROP_dirtpile_dungeon
•	 M_PROP_ember_dungeon
•	 M_PROP_goldpile_dungeon
•	 M_PROP_skeleton_bonepile_dungeon
•	 M_wood_planks_dungeon_01 

Meshes
All assets have a custom Lightmap UV in the second channel and colliders (Unity) where 
needed.

•	 M_CLR_yellow_E
•	 M_FX_fire_dungeon
•	 M_FX_fog_big_dungeon
•	 M_FX_fog_small_dungeon
•	 M_FX_glow_dungeon
•	 M_FX_gradient_linear_dungeon
•	 M_FX_steam_dungeon

FX

Atlases

•	 M_metal_dungeon_01
•	 M_metal_dungeon_02
•	 M_PROP_books_dungeon
•	 M_PROP_bottle_dungeon
•	 M_PROP_bow_dungeon
•	 M_PROP_campfire_dungeon
•	 M_PROP_candle_dungeon
•	 M_PROP_chains_dungeon
•	 M_PROP_fabric_dungeon
•	 M_PROP_flags_dungeon
•	 M_PROP_orevein_dungeon

•	 M_PROP_pot_dungeon
•	 M_PROP_sack_dungeon
•	 M_PROP_skeleton_dungeon
•	 M_PROP_spiderweb_dungeon
•	 M_PROP_stone_deco_dungeon
•	 M_PROP_tools_dungeon
•	 M_PROP_vegetation_dungeon
•	 M_PROP_weapon_dungeon
•	 M_wood_planks_dungeon_02
•	 M_wood_planks_dungeon_03
•	 M_wood_planks_dungeon_04



14

Physically Based Rendering (PBR)

With Fantastic Dungeon Pack 1.1 update we added PBR textures for the following 
texture sets (this update also includes normal maps):

•	 T_MOD_Floor_01_v1
•	 T_MOD_Floor_01_v2
•	 T_MOD_Floor_01_v3
•	 T_MOD_Trim_Stone_01_v1
•	 T_MOD_Trim_Stone_01_v2
•	 T_MOD_Trim_Stone_01_v3
•	 T_MOD_Wall_01_v1
•	 T_MOD_Wall_01_v2
•	 T_MOD_Wall_01_v3
•	 T_PROP_dirtpile_dungeon
•	 T_PROP_bonepile_dungeon
•	 T_PROP_gold_dungeon
•	 T_PROP_gold_dungeon_coins
•	 T_PROP_orevein_dungeon
•	 T_PROP_stone_deco_dungeon
•	 T_wood_planks_dungeon_01
•	 T_wood_planks_dungeon_02
•	 T_wood_planks_dungeon_03
•	 T_wood_planks_dungeon_04 

complete rework with 1.1
complete rework with 1.1
new addition with 1.1
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You can adjust 
the smoothness 
amount here

Add the corresponding 
MTSM texture here

Physically Based Rendering (PBR) - setup and how to use

The PBR textures are set up the following way:
Metallic levels for the material are controlled by the values in the Red channel 
of the texture, and the Smoothness levels for the material are controlled by the 
Alpha channel of the texture.
These textures have the tag  “_ MTSM” at the end of the texture name. 

Additionally for all these textures that would include a metal surface we added a 
variation which is not metal. 
These textures have the tag  “_ MTSM_nometal” at the end of the texture name. 

This setup works for both URP and Built-in render pipeline.
To read more about this please visit the Unity Documentation here: 
https://docs.unity3d.com/Manual/StandardShaderMetallicVsSpecular.html
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FX
Inside the \Fantastic Dungeon Pack\prefabs\FX folder you will find the various effects to 
decorate your scenes.

Fire GodraysSteam

Fog_big ParticlesFog_small

IMPORTANT: Make sure to enable “Depth Texture” in your URP Render Pipeline 
Asset, otherwise the fog won’t be displayed correctly.

The render pipeline asset settings.
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Customizing Assets

We have added multiple variants for some of the materials. For instance you will find x3 
alternative textures for walls, floors and the other modular pieces. 
Also for props we have different plank texture variations.  

You can either adjust the assets directly or create different prefab versions with different 
materials applied!

Materials
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When you inspect some of the “lightsource” assets (lamp, torch, brazier etc) , you notice 
we placed a light in some of them. 
For every “fire-based” light source (torch, etc) there is a prefab with a flickering anima-
tion on it. Adjusting that prefab directly will update all the “fire-based” prefabs auto-
matically

Light sources
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Modular Assets

Naming convention
Prefixes and suffixes

All the modular pieces follow a strict naming convention to make your life easier. You 
can use the prefixes/affixes to either search for a group of assets, or simply know in the 
scene view which asset is what.

To familiarize yourself better with the naming convention we strongly suggest looking 
into the demoscene_dungeon_assets_modular scene. There you will find ever single 
piece of the pack, with explanations where necessary. Additionaly there are also exam-
ples for various usecases:

Meshes
All assets have a custom Lightmap UV in the second channel and colliders (Unity) where 
needed.
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Prefix Suffix

P_		  Prefab
_MOD_	 Modular piece

_O_	 	 OneSided 
_M_		  PivotMiddle
_E_		  PivotEdge
_large_	 6 units
_med_	 4 units
_small_	 2 units

Some Parts and Level Modules additionaly have direction suffixes added based on 
compass directions:

_S		  Path leads to the South
_SE		  Path leads to the South and the East
_NS		  Path leads to the South and the North
_SEW		 Path leads to the South, East and the West
etc.

Examples

P_	 MOD_		  Stairs_	 01_		  E_	 angle_	 concave_	 1
Prefab		  Object type stairs			   PivotEdge		  for a concave setup
	 Modular				    Set Number		  Angled version		  variant 1

COMP_	 Door_		  01_		  med_		 02_	 O
Composition			   Set Number			   variant 02
		  Object type door			   Height 4 units	 OneSided

LVL_		  01_		  M_		  small_	 straight_	 NS
Level Module		  PivotMiddle			   straight version
		  Set Number			   Height 2 units		  Exits on north and south side
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Prefabs and Nested Prefabs
Nested Prefab hierarchy

We have 3 levels of hierarchy:
level 1: Parts - individual modular elements, baseline prefabs + collision
level 2: Comps - compositions of individual elements
level 3: Level Modules - combinations of Comps and Parts

Adjusting anything on a lower level of the hierarchy will automatically propagate up 
(except there are already changes on a higher level). Adjusting anything in a higher 
level will not automatically propagate down and you will have to manually apply your  
changes. 

Read more into the Nested Prefab workflow here:
https://docs.unity3d.com/2019.1/Documentation/Manual/NestedPrefabs.html
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Level Modules
prefabs\MODULAR\03_LEVEL_MODULES

In the Level Modules you will find multiple 
setups for different heights, angles, types of 
levels. Also here feel free to combine in a dif-
ferent way or even add some props directly in 
these prefabs for even faster level creation.

Comps
prefabs\MODULAR\02_COMPS

Here you will find some basic compositions 
of the Part prefabs. These show you how the 
elements are ment to be combined but, of 
course, feel free to experiment and create new 
ones!

Parts
prefabs\MODULAR\01_PARTS

Here you will find all the 250+ pieces of the 
baseline elements. On this level we already 
added colliders where necessary.

P_MOD_Wall_01_M_straight_med

COMP_Wall_01_M_straight_med

LVL_01_M_med_straight_S
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Examples
COMP_Column_01_med

P_MOD_Column_01_cap

P_MOD_Column_01_capital

P_MOD_Column_01_med

P_MOD_Column_01_base

P_MOD_WallCover_01_M_straight

P_MOD_Wall_01_M_straight_med

P_MOD_WallTrim_01_M_straight

COMP_Wall_01_M_straight_med
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Working with the modular pieces
Snapping

You can activate snapping by holding Control (Command) key while moving and rotat-
ing objects.
Additionaly when you go to Edit > Snap Settings you will get a very useful window. If you 
don’t use any third-party plugins for snapping, press Snap All Axes button when plac-
ing any of the modular elements into the scene. 

Generally speaking every asset need to snap on nondecimal numbers. You will notice, 
that for this rule there are some exceptions when combining certain elements that do 
not naturally match. 
When working with PivotEdge walls for example, if you want to place Columns at those 
walls you can move them by 0.25 units to reveal more volume of the columns. 
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Blocking out a level

Step 1: 
Take the Base prefabs and/or OneSided walls 
and block out the volume of your level.

You can find these prefabs here: 
prefabs\MODULAR\01_PARTS\Base
and here:
prefabs\MODULAR\01_PARTS\Wall\OneSided

Step 2:
Take Comps and Level Module prefabs 
and add them to the blockout. 

You can find these prefabs here: 
prefabs\MODULAR\02_COMPS 
and here:
prefabs\MODULAR\03_LEVEL_MODULES

Step 3: 
And last but not least add some decora-
tional props!

You can find these prefabs here: 
prefabs\PROPS

You can also start with Step 2 as the 
blockout step, followed by Step 1. to 
cover gaps. 
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Support

FAQ

Yes. We plan to update all our packages as soon as there is a relevant update or if the 
community asks for adjustments. 

Yes, but first please read through this document and if you still need help with some-
thing related to this package, feel free to contact us. 

Will there be updates to the package?

Can you give support to users if something doesn’t work?

Try reimporting the shader (in project tab > right-click on the shader > Reimport). 
We are aware of some shader warnings showing up, which don’t seem to actually break 
the shader. So simply clearing the warning in the console tab should fix the problem.

With Unity 2019.3 the Lightweight Render Pipeline is renamed to Universal Render 
Pipeline. If you set up your project using LWRP from an older version of our pack, you 
can change to URP and everything should work from the getgo - shaders, materials and 
lighting are compatible with URP. 

A list of errors shows up in a shader.

What’s the deal with Universal Render Pipeline (URP)?

This is the case when your project doesn’t use the same render pipeline as the pack 
version you installed. Starting on page 4 you will find all the steps needed to properly 
set up your project. 

I opened the project for the first time and everything is pink. When I se-

lect a material, the shader says “Hidden/InternalErrorShader”
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Make sure you installed the correct render pipeline version of our pack. After opening a 
scene it’s still possible, that some assets are pink. If that is the case, do the following:
•	 In the Hierarchy window select “Terrain”
•	 In the “Paint Details” tab double click on any asset
•	 Click on the circle next to the asset which was added in the “Detail” panel
•	 Re-add the same asset and the scene should look normal again

If you see any pink assets inside the Project window or inside the “Terrain”-object in any 
of the scenes simply select the said Prefabs (inside the prefabs folder) or the Meshes 
(inside the 3d folder) > right click > Reimport and it should fix it. 

I imported the package but some assets still appear pink in the scene...

I imported the package but some assets still appear pink in the 

Project window...

Regarding pink assets and terrain issues please see the chapters 1, 2 and 3.
The new URP shaders are created in Unity 2019.4.30 and are not backwards compatible. 
The errors is created by the shadow cascades settings in the render pipeline asset. You 
can set the Cascades option in your render pipeline asset to “No Cascades”. 

I’m using Unity version older than 2019.4.30 and the scene assets have 

shadow errors and/or pink materials and/or the terrain isn’t showing. 

Make sure to enable “Depth Texture” in your URP Render Pipeline Asset, otherwise the 
fog appears “cut off” when it intersects with a mesh. 

The fog isn’t displayed correctly.
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Contact & Support

Social Media

Visit our page for updates and more packages in the future:
https://tidalflask.com/

Contact us if you didn’t find an answer to your questions:
info@tidalflask.com

https://www.facebook.com/tidalflask

https://twitter.com/TidalFlask

https://www.instagram.com/tidalflask/


